We’re experiencing some delays in outbound emails being sent through our email service provider
Incident Report for InVision
Resolved
This incident is now resolved and all emails should be sent without delay. Apologies for any inconvenience!
Posted 2 months ago. May 15, 2018 - 16:26 EDT
Update
This is impacting all customers including customers on our Private Cloud service.
Posted 2 months ago. May 15, 2018 - 15:10 EDT
Investigating
We’re experiencing some delays in outbound emails being sent through our email service provider. We’re monitoring the situation closely and will provide an update when we have further information.
Posted 2 months ago. May 15, 2018 - 15:06 EDT
This incident affected: InVision.