Craft Freehand panel displays as blank on September 9, 2017
Incident Report for InVision
Resolved
We've resolved the issue where the Craft Freehand panel showed as blank. Apologies for the inconvenience!
Posted Sep 08, 2017 - 15:40 EDT
Investigating
We're currently investigating the Craft Freehand panel showing as blank. Stay tuned for updates!
Posted Sep 08, 2017 - 12:34 EDT