Several InVisionapp account signup promotions currently not working
Incident Report for InVision
Resolved
We're seeing that signup promotions are now working and are considering this issue to be resolved.
Posted about 1 month ago. Apr 09, 2018 - 08:33 EDT
Identified
We've identified the issue and are working towards a resolution
Posted about 1 month ago. Apr 09, 2018 - 07:37 EDT
Investigating
We are currently investigating reports of several of our signup promotion landing pages leading to an "Unexpected Error" page
Posted about 1 month ago. Apr 09, 2018 - 07:15 EDT