Support Portal is intermittently inaccessible on 06/12/18
Incident Report for InVision
Resolved
We're pleased to report that our Support Portal should now be operating as expected.
Posted 7 days ago. Jun 12, 2018 - 17:27 EDT
Investigating
We're working with our vendor to investigate an issue that is impacting connectivity to our support portal and Help Center. We will update as this situation advances.
Posted 7 days ago. Jun 12, 2018 - 16:28 EDT
This incident affected: Support Portal.