Public share links are displaying "This link is no longer valid." message
Incident Report for InVision
Resolved
The issue formerly impacting Share Links to display as invalid is now resolved. We appreciate your patience while our engineers worked to resolve the problem.
Posted about 1 month ago. Apr 16, 2018 - 12:57 EDT
Monitoring
The issue with the share links should be resolved, we'll continue to monitor the status.
Posted about 1 month ago. Apr 15, 2018 - 20:10 EDT
Investigating
We're investigating an issue surrounding the loading of public share links.
Posted about 1 month ago. Apr 15, 2018 - 17:42 EDT