Users are unable to access our Support Hub (https://support.invisionapp.com/)
Incident Report for InVision
Resolved
This incident has been resolved. Thank you for your patience and Happy New Year!
Posted Jan 03, 2023 - 05:09 EST
Investigating
We are currently investigating an issue where users are unable to access our Support Hub (https://support.invisionapp.com/). In the meantime, if you need to submit a ticket, please email support@invisionapp.com. Apologies for any frustration this is causing!
Posted Jan 02, 2023 - 23:16 EST
This incident affected: Help Center.