Some users are unable to view or create Boards
Incident Report for InVision
Resolved
We have resolved the error that prevented boards from being loaded and viewed.
Posted 2 months ago. Aug 05, 2019 - 14:37 EDT
Monitoring
We have identified and implemented a fix to resolve the intermittent board errors. We'll continue to monitor performance of boards moving forward.
Posted 2 months ago. Aug 05, 2019 - 14:17 EDT
Investigating
Some users are unable to view or create Boards and may receive error message "Boards didn't load correctly. Sorry about that. Try again?"
Posted 2 months ago. Aug 05, 2019 - 12:57 EDT
This incident affected: InVision.