Some user may encounter Freehand connection failures
Incident Report for InVision
Resolved
This incident has been resolved, and users should no longer encounter connectivity issues accessing their Freehands. Thanks again for your patience.
Posted Feb 16, 2023 - 15:20 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 16, 2023 - 15:12 EST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2023 - 14:51 EST
Investigating
We are currently investigating a re-occurrence of an issue that is causing connectivity issues for those accessing Freehand documents.
Posted Feb 16, 2023 - 14:15 EST
This incident affected: Freehand.