Private Cloud users may see errors when loading Studio's App Store
Incident Report for InVision
Resolved
Our Studio Engineering team have since now resolved the issue whereby the Studio App Store was failing to load for some users on Private Cloud.

We thank you for your patience as we worked to resolve this. Please do reach out at support@invisionapp.com, should there be anything further we can assist with.
Posted 27 days ago. Jun 24, 2019 - 05:23 EDT
Update
Our Studio Engineering team is continuing to investigate an issue where Studio App Store is failing to load for some users on Private Cloud. No good news to share yet, but we're on our way to a resolution. If you, or your team is running into this problem, please drop a note to support@invisionapp.com.
Posted 27 days ago. Jun 24, 2019 - 01:57 EDT
Update
Updated the status to include Private Cloud.
Posted 27 days ago. Jun 24, 2019 - 00:32 EDT
Investigating
Some Private Cloud users may see a 'Something went wrong' error when loading Studio's App Store. We are currently investigating the cause of this issue.
Posted 27 days ago. Jun 24, 2019 - 00:30 EDT
This incident affected: Private Cloud and Studio.