Our Support Hub and Help Centre are not available
Incident Report for InVision
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 02:02 EST
Identified
We're still working on fixing all redirects, however you should be able to access the Support Hub via https://support.invisionapp.com/.
Posted Dec 18, 2023 - 09:50 EST
Update
We're still investigating the root cause, however you should be able to access the Support Hub via https://support.invisionapp.com/.
Posted Dec 18, 2023 - 08:31 EST
Investigating
We are currently investigating the issue affecting our Support Hub and Help Centre at https://support.invisionapp.com/hc/en-us. If you need urgent assistance, please contact support@invisionapp.com. We apologize for any inconvenience this may cause.
Posted Dec 18, 2023 - 03:09 EST
This incident affected: Help Center.