projects.invisionapp.com slow to load
Incident Report for InVision
Resolved
Our Engineering Team has considered this issue to be resolved, and load times should be as expected. Our apologies for the inconvenience here!
Posted 9 months ago. Nov 27, 2018 - 13:42 EST
Monitoring
We have noticed load times stabilize to their normal times, and are currently monitoring this issue.
Posted 9 months ago. Nov 27, 2018 - 12:27 EST
Investigating
We experienced a hiccup causing delays loading projects.invisionapp.com
Posted 9 months ago. Nov 27, 2018 - 11:54 EST
This incident affected: InVision.