Some user may encounter Freehand connection failures
Incident Report for InVision
Resolved
This incident has been resolved, users should no longer encounter connectivity issues accessing their Freehands. We appreciate your patience.
Posted Feb 16, 2023 - 13:13 EST
Investigating
We are currently investigating an issue that is causing connectivity issues for those accessing Freehand.
Posted Feb 16, 2023 - 12:33 EST
This incident affected: Freehand.