Freehand projects fail to delete
Incident Report for InVision
Resolved
This incident has been resolved.
Posted Aug 23, 2021 - 13:35 EDT
Investigating
We are currently investigating reported trouble with deleting Freehand projects.
Posted Aug 23, 2021 - 12:42 EDT
This incident affected: InVision Cloud V6 (Freehand).