Users are unable to access our Support Hub (https://support.invisionapp.com/)
Incident Report for InVision
Resolved
This issue has been resolved and all services are fully functional! We're very sorry for the frustration it might have caused.
Posted Jan 04, 2023 - 03:27 EST
Update
We are continuing to investigate this issue.
Posted Jan 03, 2023 - 09:15 EST
Investigating
We are currently investigating an issue where users are unable to access our Support Hub (https://support.invisionapp.com/). In the meantime, if you need to submit a ticket, please email support@invisionapp.com. Apologies for any frustration this is causing!
Posted Jan 03, 2023 - 05:14 EST
This incident affected: Help Center.