Freehand projects fail to load for some customers in V7.
Incident Report for InVision
Resolved
This incident has been resolved.
Posted Aug 26, 2021 - 15:32 EDT
Investigating
We are currently investigating reports of trouble loading Freehand projects for some customers.
Posted Aug 26, 2021 - 15:30 EDT
This incident affected: Freehand.