Some users may experience slow loading times
Incident Report for InVision
Resolved
The cause of the slow down has been identified and rectified. Everything should be working as expected now! If you continue to have trouble, please reach out and let us know! Apologies for the disruption.
Posted 24 days ago. Nov 20, 2018 - 11:26 EST
Investigating
We recently became aware of an issue causing some users to experience slow load times when accessing projects.invisionapp.com. We are working to resolve the issue. We do not have any reason to believe this impacts our Private Cloud customers.
Posted 24 days ago. Nov 20, 2018 - 11:11 EST
This incident affected: InVision.