Delayed email notifications
Incident Report for InVision
Resolved
This issue is resolved and email notifications are now being sent as expected. Again, we apologize for the troubles this has caused!
Posted 2 months ago. Jul 03, 2019 - 13:18 EDT
Update
We're still investigating an issue where some users may experience delays in email notifications from InVision.
Posted 2 months ago. Jul 03, 2019 - 11:58 EDT
Investigating
We are currently investigating an issue that may prevent some users from receiving timely email notifications.
Posted 2 months ago. Jul 03, 2019 - 11:12 EDT
This incident affected: InVision.