Sending and receiving of customer requests is unavailable 24/07/2019
Incident Report for InVision
Resolved
We're happy to report that the issues we were experiencing sending and receiving requests through our vendor have now been resolved. All customers should now be able to get in touch with Support via the normal routes without any trouble!
Posted 29 days ago. Jul 24, 2019 - 06:32 EDT
Update
We are working with our vendor to investigate an issue that is impacting the sending and receiving of requests through our support portal, which will result in some delays to our responses to customer queries. In the interim, all customers wishing to get in touch can email support@invisionapp.com. Please be advised email may also be subject to delays. We will update as the situation advances.
Posted 29 days ago. Jul 24, 2019 - 04:59 EDT
Investigating
We are working with our vendor to investigate an issue that is impacting the sending and receiving of requests through our support portal, which will result in some delays to our responses to customer queries. We will update as the situation advances.
Posted 29 days ago. Jul 24, 2019 - 04:39 EDT
This incident affected: Support Portal.