Some users are not able to access their invoices
Incident Report for InVision
Resolved
Our engineers have released a fix for the issue and invoices can be accessed again.
Posted Jul 05, 2021 - 14:29 EDT
Identified
We have identified the issue and are working on a resolution.
Posted Jul 05, 2021 - 12:36 EDT
Update
We are continuing to investigate this issue.
Posted Jul 05, 2021 - 10:25 EDT
Investigating
We are currently investigating an issue where some users are unable to access their billing invoices.
Posted Jul 05, 2021 - 09:34 EDT
This incident affected: InVision Cloud V6 (Authentication and user management) and InVision Cloud V7 (Authentication and user management).