Intermittent issues with loading home page and documents
Incident Report for InVision
Resolved
The fix has been implemented and we can confirm services have been fully restored.
Posted 3 months ago. Jun 03, 2019 - 22:48 EDT
Identified
We have identified the root cause of the issue and we're actively working on a fix at the moment.
Posted 3 months ago. Jun 03, 2019 - 22:43 EDT
Investigating
We're currently investigating an intermittent issue where users are unable to load home page and documents.
Posted 3 months ago. Jun 03, 2019 - 21:49 EDT
This incident affected: InVision.