Freehand projects fail to load for some customers in V7
Incident Report for InVision
Resolved
We have identified the root cause of the issue and the issue has now been resolved.
Posted Aug 06, 2021 - 13:04 EDT
Monitoring
We discovered an issue where some of our customers were briefly unable to access Freehand.
Posted Aug 06, 2021 - 13:03 EDT
This incident affected: Freehand.