Users are unable to access InVision Help Center
Incident Report for InVision
Resolved
The fix has been implemented. Users should be able to access Help Center without issues. Apologies for the trouble caused!
Posted May 30, 2021 - 21:43 EDT
Identified
We have identified the cause of the issue and are currently working on a fix.
Posted May 30, 2021 - 21:13 EDT
Investigating
We are currently investigating an issue where users are unable to access InVision Help Center
Posted May 30, 2021 - 20:37 EDT
This incident affected: Help Center.