Issues applying text styles, layer styles, or drag-and-dropping layers from DSM Craft plugin after update to Sketch 52
Incident Report for InVision
Resolved
This incident has been resolved with an update to the DSM plugin. Please ensure you update to the latest version of the DSM plugin (1.0.9), and give us a shout if you run into any further troubles!
Posted 2 months ago. Oct 02, 2018 - 15:33 EDT
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Oct 02, 2018 - 12:52 EDT
Update
Engineers are still tackling the issue, making good progress. We apologize for the inconvenience caused!
Posted 2 months ago. Oct 02, 2018 - 11:40 EDT
Identified
Our engineers have identified the root cause and are working on restoring functionality. We also have found that the issue is causing the DSM plugin to freeze when trying to add new elements.
Posted 2 months ago. Oct 02, 2018 - 11:06 EDT
Update
Our engineers are still looking for ways to restore the functionality within DSM. In the meantime, though not ideal, we would recommend remaining on the prior version of Sketch if Craft DSM is part of your workflow
Posted 2 months ago. Oct 02, 2018 - 10:29 EDT
Investigating
We are currently investigating an issue where users are presented an error message when trying to apply text or layer styles, or drag-and-drop layers into their Sketch file from our Craft DSM plugin.

The web view of DSM is not affected.
Posted 2 months ago. Oct 02, 2018 - 09:54 EDT
This incident affected: Design System Manager.