Some users are unable to access Billing page
Incident Report for InVision
Resolved
This issue has been resolved and Billing page can be accessed now.
Posted 2 months ago. Apr 09, 2019 - 21:40 EDT
Identified
Issue has been identified and we are currently working to release a fix for the issue.
Posted 2 months ago. Apr 09, 2019 - 21:28 EDT
Investigating
We're currently investigating an issue where some users are unable to access Billing page.
Posted 2 months ago. Apr 09, 2019 - 20:28 EDT
This incident affected: Billing.