Issues with accessing billing invoices
Incident Report for InVision
Resolved
The issue has been identified and resolved! Apologies for the disruption.
Posted Nov 25, 2019 - 14:56 EST
Investigating
We are currently investigating an issue where users are unable to see past billing invoices.
Posted Nov 25, 2019 - 14:44 EST
This incident affected: InVision Cloud V6 (Flat prototypes).