Unable to download Studio from https://www.invisionapp.com/studio
Incident Report for InVision
Resolved
The outage has been resolved, the ability to download Studio is once more available from https://www.invisionapp.com/studio
Posted Oct 05, 2018 - 06:00 EDT
Investigating
We're currently investigating an issue where Studio cannot be downloaded from https://www.invisionapp.com/studio due to "An unexpected error has occurred." message.
Posted Oct 05, 2018 - 03:10 EDT
This incident affected: InVision Website (InVision Website).