Freehand users on Chrome v73 may experience some issues with zooming
Incident Report for InVision
Resolved
This issue has been resolved. Users should be able to use Freehand as expected on Chrome 73.
Posted 5 months ago. Mar 18, 2019 - 17:11 EDT
Identified
The issue and a fix have been identified. We are working on implementing the fix.
Posted 5 months ago. Mar 18, 2019 - 16:36 EDT
Investigating
We are currently investigating this issue.
Posted 5 months ago. Mar 18, 2019 - 16:22 EDT
This incident affected: Freehand.