InVision Projects failing to load on 9/20
Incident Report for InVision
Resolved
Services have been fully restored, and we believe the immediate issue is resolved. Thanks for your patience with us!
Posted Sep 20, 2017 - 14:16 EDT
Investigating
We're investigating an issue resulting in a 500 internal server error on the InVision Projects page. We're on the case!
Posted Sep 20, 2017 - 13:50 EDT