Studio Installer Download Not Automatically Starting After Registering
Incident Report for InVision
Resolved
This issue has been resolved. The download should now start automatically after successfully filling out the registration form. Please clear your local browsing cache if you still experience an issue.
Posted May 25, 2018 - 08:29 EDT
Investigating
After registering for access to Studio on https://www.invisionapp.com/studio the download for the installer is not automatically starting. If you reload the page after filling out the form, you can manually start the download via the download button.
Posted May 25, 2018 - 06:25 EDT
This incident affected: InVision Website (InVision Website).